Topic: What version of Ruby on Rails should I use?

I just started learning Ruby on Rails and installed Instant Rails 2.0 Windows. I've been looking at various books and video tutorials to learn but then I discovered that there were changes to version 2.0 (like with scaffolding) that meant I couldn't just follow the books and tutorials I was using! Do you think I should use the latest version and spend time learning any changes or just use an earlier version?

Here's some of the questions that might be relevant:
Are there fairly comprehensive and gentle beginning tutorials for the latest version?
Are there crucial security updates or important features the latest version has and previous versions lack?
Is it easy to update an application written in an earlier version for the latest version, and are there gentle tutorials for doing so?
What versions are most represented by the more complete currently existing books and tutorials for learning RoR?