Topic: Problem upgrading Rails.

okay I've been running 1.1.2 on my machine for a while and decided to upgrade to 1.1.6. and I keep getting errors.


I get this one if I try :gem update
ERROR:  While executing gem ... (Errno::EACCES)
    Permission denied - /usr/lib/ruby/gems/1.8/cache/actionpack-1.12.5.gem

This one if I try :gem install rails
ERROR:  While executing gem ... (Errno::EACCES)
    Permission denied - /usr/lib/ruby/gems/1.8/cache/activerecord-1.14.4.gem


any ideas?

--

Re: Problem upgrading Rails.

try:

sudo gem install rails

Railscasts - Free Ruby on Rails Screencasts

Re: Problem upgrading Rails.

as ever ryanb has the answer.

thanks it worked with out any hic ups. tested an app with it and it seems to work fine.

--