Topic: NetBeans Error :Rails requires RubyGems >= 1.3.1

Hi all
I'm using Netbeans 6
My rails version is 2.2.2, gem version 1.3.1.Ruby 1.8.6. But when I try to create Models using rails generator I get the following error.

"Rails requires RubyGems >= 1.3.1 (you have 1.1.1). Please `gem update --system` and try again."

I am not using the built-in Ruby interpreter for NetBeans.
Has anyone come accross this before?

Thanks
GoodNews

Re: NetBeans Error :Rails requires RubyGems >= 1.3.1

In a console out of netbeans, what do you see if you type "gem -v" ?

Re: NetBeans Error :Rails requires RubyGems >= 1.3.1

Hi
As I mentioned It gives 1.3.1. I tried upgrading the gems using 'gem update --system' it says nothing to update!.

Re: NetBeans Error :Rails requires RubyGems >= 1.3.1

But I'm able 'generate' using the console.

Re: NetBeans Error :Rails requires RubyGems >= 1.3.1

ok....
Fixed it.

Just go to ->File/'ProjectName' Properties/
and change the interpreter it uses.

If gem,rails,ruby versions are up to date this should work.

Cheers