Topic: webrick server error

hi

         I have downloaded application of ROR through svn . when i try to start webrick server gives following error:

=> Booting WEBrick...
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/servers/webrick.rb:11: w
arning: already initialized constant OPTIONS
./script/../config/../vendor/plugins/bundled_resource-0.9/init.rb:33:in `load_pl
ugin': (eval):1:in `load_plugin': undefined method `bundle' for module `BundledR
esource::DynarchCalendar' (NameError)
        from ./script/../config/../vendor/plugins/bundled_resource-0.9/init.rb:2
3:in `each'
        from ./script/../config/../vendor/plugins/bundled_resource-0.9/init.rb:2
3:in `load_plugin'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:348:i
n `load_plugin'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/core_ext/kernel/reporting.rb:11:in `silence_warnings'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:348:i
n `load_plugin'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:158:i
n `load_plugins'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:158:i
n `each'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:158:i
n `load_plugins'
         ... 12 levels...
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in `require'
        from script/server:3

Thanks in advance

Re: webrick server error

It sounds like it's a bug in the bundled_resource plugin.  Perhaps you could ask the creator of this code what's going on?