Topic: Rails 2.2 mysql.rb driver has been removed!

I am trying to run a new application and just updated my rails version. I try to connect MySQL database but I get this error ->

!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
rake aborted!
no such file to load -- mysql

<--

Anyone can help ?? I tried some commands found on the net trying to fix it but nothing seems to be working.

Re: Rails 2.2 mysql.rb driver has been removed!

Demec,
I doubt you're still working on this problem as you posted 3 months ago and if you still need help, send me an email. Are you working on Windows?
David

Re: Rails 2.2 mysql.rb driver has been removed!

Hey,
Am facing the same problem...Any fixes ?

I have Rails 2.2.2 on windows...
Ruby 1.8.6
And I had installed mysql-2.7.3-x86-mswin32...

when I do rake db:migrate, I get this problem :
"rake aborted!
Mysql::Error: Commands out of sync; you can't run this command now: SHOW TABLES

(See full trace by running task with --trace)
D:/Arsenal/Ruby/bin/rake:19: [BUG] Segmentation fault
ruby 1.8.6 (2008-08-11) [i386-mswin32]


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."


So I uninstalled mysql, using gem uninstall mysql...
I already have mysql 5.1 installed on my windows, but seems we cannot use that, so we need to do gem install mysql (don't know why)...

So now how do I get around it, because now that i have uninstalled mysql from the ruby system, how do I install mysql, because now I get

"
D:\Arsenal\RoR\photos>rake db:migrate
(in D:/Arsenal/RoR/photos)
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install
the mysql gem and try again: gem install mysql.
rake aborted!
no such file to load -- mysql"

Re: Rails 2.2 mysql.rb driver has been removed!

Do you have your PATH pointing to MySQL library. It's located at D:\MySQL\MySQL Server 5.0\lib\opt. My friend have the same problem, but she's using 5.1 and I'm using 5.0.45. So she just copy the library over and set it in the PATH.